const regex = /(https?:\/\/\S+)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(https?:\\\/\\\/\\S+)$', 'gm')
const str = `<div class="text">
http://2gis.ru
http://www.yp.ru
http://www.yell.ru
http://www.ypag.ru
http://www.e-adres.ru
http://infolo.ru
http://globalmcom.com
</div>`;
const subst = `$1<br>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);