re = /(https?:\/\/\S+)$/m
str = '<div class="text">
http://2gis.ru
http://www.yp.ru
http://www.yell.ru
http://www.ypag.ru
http://www.e-adres.ru
http://infolo.ru
http://globalmcom.com
</div>'
subst = '$1<br>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result