use strict;
my $str = '<div class="text">
http://2gis.ru
http://www.yp.ru
http://www.yell.ru
http://www.ypag.ru
http://www.e-adres.ru
http://infolo.ru
http://globalmcom.com
</div>';
my $regex = qr/(https?:\/\/\S+)$/mp;
my $subst = '$1<br>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";