// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(https?:\/\/\S+)$").unwrap();
let string = "<div class=\"text\">
http://2gis.ru
http://www.yp.ru
http://www.yell.ru
http://www.ypag.ru
http://www.e-adres.ru
http://infolo.ru
http://globalmcom.com
</div>";
let substitution = "$1<br>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}