$re = '/^.*(?=(?:\s+\S+){2}$)/m';
$str = 'Level production data TD Index
Total Agriculture\\Production data TS Index';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;