re = /^.*(?=(?:\s+\S+){2}$)/m
str = 'Level production data TD Index
Total Agriculture\\Production data TS Index'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result