import re
regex = re.compile(r"^.*(?=(?:\s+\S+){2}$)", flags=re.MULTILINE)
test_str = ("Level production data TD Index\n"
"Total Agriculture\\Production data TS Index")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)