#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<a.*\>{1}(.*)<\/a>"
Local $sString = "<p>random <b>html content</b> <a href="http://www.google.com" target="_blank" data-saferedirecturl="https://www.google.com/url?hl=fr&q=http://www.randomsite.com&source=gmail&ust=1481293002613000&usg=AFQjCNHR0HJfUDpRN_7vq022fQiLzXf0yQ"><span class="il">content</span>.n1</a> fdfdf<br/>dsdsd <a href="dsdsdsds">content n2</a>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")