$re = '/<a.*\>{1}(.*)<\/a>/';
$str = '<p>random <b>html content</b> <a href="http://www.google.com" target="_blank" data-saferedirecturl="https://www.google.com/url?hl=fr&q=http://www.randomsite.com&source=gmail&ust=1481293002613000&usg=AFQjCNHR0HJfUDpRN_7vq022fQiLzXf0yQ"><span class="il">content</span>.n1</a> fdfdf<br/>dsdsd <a href="dsdsdsds">content n2</a>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);