using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a.*\>{1}(.*)<\/a>";
string input = @"<p>random <b>html content</b> <a href=""http://www.google.com"" target=""_blank"" data-saferedirecturl=""https://www.google.com/url?hl=fr&q=http://www.randomsite.com&source=gmail&ust=1481293002613000&usg=AFQjCNHR0HJfUDpRN_7vq022fQiLzXf0yQ""><span class=""il"">content</span>.n1</a> fdfdf<br/>dsdsd <a href=""dsdsdsds"">content n2</a>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}