# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<a.*\>{1}(.*)<\/a>"
test_str = "<p>random <b>html content</b> <a href=\"http://www.google.com\" target=\"_blank\" data-saferedirecturl=\"https://www.google.com/url?hl=fr&q=http://www.randomsite.com&source=gmail&ust=1481293002613000&usg=AFQjCNHR0HJfUDpRN_7vq022fQiLzXf0yQ\"><span class=\"il\">content</span>.n1</a> fdfdf<br/>dsdsd <a href=\"dsdsdsds\">content n2</a>"
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.