// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"<a.*\>{1}(.*)<\/a>").unwrap();
let string = "<p>random <b>html content</b> <a href=\"http://www.google.com\" target=\"_blank\" data-saferedirecturl=\"https://www.google.com/url?hl=fr&q=http://www.randomsite.com&source=gmail&ust=1481293002613000&usg=AFQjCNHR0HJfUDpRN_7vq022fQiLzXf0yQ\"><span class=\"il\">content</span>.n1</a> fdfdf<br/>dsdsd <a href=\"dsdsdsds\">content n2</a>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}