import Foundation
let pattern = #"<a.*\>{1}(.*)<\/a>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"<p>random <b>html content</b> <a href="http://www.google.com" target="_blank" data-saferedirecturl="https://www.google.com/url?hl=fr&q=http://www.randomsite.com&source=gmail&ust=1481293002613000&usg=AFQjCNHR0HJfUDpRN_7vq022fQiLzXf0yQ"><span class="il">content</span>.n1</a> fdfdf<br/>dsdsd <a href="dsdsdsds">content n2</a>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)