import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<a.*\\>{1}(.*)<\\/a>";
final String string = "<p>random <b>html content</b> <a href=\"http://www.google.com\" target=\"_blank\" data-saferedirecturl=\"https://www.google.com/url?hl=fr&q=http://www.randomsite.com&source=gmail&ust=1481293002613000&usg=AFQjCNHR0HJfUDpRN_7vq022fQiLzXf0yQ\"><span class=\"il\">content</span>.n1</a> fdfdf<br/>dsdsd <a href=\"dsdsdsds\">content n2</a>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}