use strict;
my $str = '<p>random <b>html content</b> <a href="http://www.google.com" target="_blank" data-saferedirecturl="https://www.google.com/url?hl=fr&q=http://www.randomsite.com&source=gmail&ust=1481293002613000&usg=AFQjCNHR0HJfUDpRN_7vq022fQiLzXf0yQ"><span class="il">content</span>.n1</a> fdfdf<br/>dsdsd <a href="dsdsdsds">content n2</a>';
my $regex = qr/<a.*\>{1}(.*)<\/a>/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}