# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\{'[^']+':\s*\['([^][]+)'\]}/\1/gm;t' <<< "email id
{'email': ['test@test.com']} {'id': ['123abc_d456_789_fgh']}"