#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\{'[^']+':\s*\['([^][]+)'\]}"
Local $sString = "email id" & @CRLF & _
"{'email': ['test@test.com']} {'id': ['123abc_d456_789_fgh']}"
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)