const regex = new RegExp('\\{\\'[^\\']+\\':\\s*\\[\\'([^][]+)\\'\\]}', 'gm')
const str = `email id
{'email': ['test@test.com']} {'id': ['123abc_d456_789_fgh']}`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);