$re = '/\{\'[^\']+\':\s*\[\'([^][]+)\'\]}/m';
$str = 'email id
{\'email\': [\'test@test.com\']} {\'id\': [\'123abc_d456_789_fgh\']}';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;