package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\{'[^']+':\s*\['([^][]+)'\]}`)
var str = `email id
{'email': ['test@test.com']} {'id': ['123abc_d456_789_fgh']}`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}