using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\{'[^']+':\s*\['([^][]+)'\]}";
string substitution = @"\1";
string input = @"email id
{'email': ['test@test.com']} {'id': ['123abc_d456_789_fgh']}";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}