import Foundation
let pattern = #"\{'[^']+':\s*\['([^][]+)'\]}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
email id
{'email': ['test@test.com']} {'id': ['123abc_d456_789_fgh']}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)