use strict;
my $str = 'email id
{\'email\': [\'test@test.com\']} {\'id\': [\'123abc_d456_789_fgh\']}';
my $regex = qr/\{'[^']+':\s*\['([^][]+)'\]}/mp;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";