# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\"--CVP.*(<sip:.*@.*)"
test_str = ("\"--CVP_11_5_1_0_1_0_349\" <sip:05335816023@10.134.27.2>;tag=1417F2E5-2588\n"
"\"Emre Sumengen\" <sip:3321@10.134.27.2>;tag=1417F2E5-2588\n"
"\"--CVP_13_00xx..ssdadsalds_349\" <sip:05335816023@10.134.27.2>;tag=1417F2E5-2588\n")
subst = "\\1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.