#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b[A-Za-z]:(\\[^\\\/:*?\x22<>|\r\n]+){3}$"
Local $sString = "Directory of C:\whatever" & @CRLF & _
"Directory of C:\whatever\path that" & @CRLF & _
"Directory of C:\whatever\path that\might" & @CRLF & _
"Directory of C:\whatever\path that\might\even be" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")