// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b[A-Za-z]:(\\[^\\\/:*?\x22<>|\r\n]+){3}$").unwrap();
let string = "Directory of C:\\whatever
Directory of C:\\whatever\\path that
Directory of C:\\whatever\\path that\\might
Directory of C:\\whatever\\path that\\might\\even be
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}