const regex = /\b[A-Za-z]:(\\[^\\\/:*?\x22<>|\r\n]+){3}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b[A-Za-z]:(\\\\[^\\\\\\\/:*?\\x22<>|\\r\\n]+){3}$', 'gm')
const str = `Directory of C:\\whatever
Directory of C:\\whatever\\path that
Directory of C:\\whatever\\path that\\might
Directory of C:\\whatever\\path that\\might\\even be
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}