$re = '/\b[A-Za-z]:(\\\\[^\\\\\/:*?\x22<>|\r\n]+){3}$/m';
$str = 'Directory of C:\\whatever
Directory of C:\\whatever\\path that
Directory of C:\\whatever\\path that\\might
Directory of C:\\whatever\\path that\\might\\even be
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);