import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b[A-Za-z]:(\\\\[^\\\\\\/:*?\\x22<>|\\r\\n]+){3}$";
final String string = "Directory of C:\\whatever\n"
+ "Directory of C:\\whatever\\path that\n"
+ "Directory of C:\\whatever\\path that\\might\n"
+ "Directory of C:\\whatever\\path that\\might\\even be\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}