re = /\b[A-Za-z]:(\\[^\\\/:*?\x22<>|\r\n]+){3}$/m
str = 'Directory of C:\\whatever
Directory of C:\\whatever\\path that
Directory of C:\\whatever\\path that\\might
Directory of C:\\whatever\\path that\\might\\even be
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end