package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b[A-Za-z]:(\\[^\\\/:*?\x22<>|\r\n]+){3}$`)
var str = `Directory of C:\whatever
Directory of C:\whatever\path that
Directory of C:\whatever\path that\might
Directory of C:\whatever\path that\might\even be
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}