using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b[A-Za-z]:(\\[^\\\/:*?\x22<>|\r\n]+){3}$";
string input = @"Directory of C:\whatever
Directory of C:\whatever\path that
Directory of C:\whatever\path that\might
Directory of C:\whatever\path that\might\even be
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}