# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\d\d:\d\d%:\d\d(*SKIP)(*FAIL)|(?<!\\)%.*//gm;t' <<< "for 10\% and %delete-me
for 10\% and 2021-03-09 Tue 02:59%:02 NO DELETE %delete-me
for 10\% and 2021-03-09 Tue 04:09%anything %delete-me
for 10 percent%delete-me'"