import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d\\d:\\d\\d%:\\d\\d(*SKIP)(*FAIL)|(?<!\\\\)%.*";
final String string = "for 10\\% and %delete-me\n"
+ "for 10\\% and 2021-03-09 Tue 02:59%:02 NO DELETE %delete-me\n"
+ "for 10\\% and 2021-03-09 Tue 04:09%anything %delete-me\n"
+ "for 10 percent%delete-me'";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}