#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\d\d:\d\d%:\d\d(*SKIP)(*FAIL)|(?<!\\)%.*"
Local $sString = "for 10\% and %delete-me" & @CRLF & _
"for 10\% and 2021-03-09 Tue 02:59%:02 NO DELETE %delete-me" & @CRLF & _
"for 10\% and 2021-03-09 Tue 04:09%anything %delete-me" & @CRLF & _
"for 10 percent%delete-me'"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)