const regex = /\d\d:\d\d%:\d\d(*SKIP)(*FAIL)|(?<!\\)%.*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d\\d:\\d\\d%:\\d\\d(*SKIP)(*FAIL)|(?<!\\\\)%.*', 'gm')
const str = `for 10\\% and %delete-me
for 10\\% and 2021-03-09 Tue 02:59%:02 NO DELETE %delete-me
for 10\\% and 2021-03-09 Tue 04:09%anything %delete-me
for 10 percent%delete-me'`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);