import re
regex = re.compile(r"\d\d:\d\d%:\d\d(*SKIP)(*FAIL)|(?<!\\)%.*", flags=re.MULTILINE)
test_str = ("for 10\\% and %delete-me\n"
"for 10\\% and 2021-03-09 Tue 02:59%:02 NO DELETE %delete-me\n"
"for 10\\% and 2021-03-09 Tue 04:09%anything %delete-me\n"
"for 10 percent%delete-me'")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)