use strict;
my $str = 'for 10\\% and %delete-me
for 10\\% and 2021-03-09 Tue 02:59%:02 NO DELETE %delete-me
for 10\\% and 2021-03-09 Tue 04:09%anything %delete-me
for 10 percent%delete-me\'';
my $regex = qr/\d\d:\d\d%:\d\d(*SKIP)(*FAIL)|(?<!\\)%.*/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";