import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "@((?:[\\s\\S](?!\\*\\/|@))*)";
final String string = "/**\n"
+ " * Queries the data and returns the value for the given x, y cartesian\n"
+ " * pair\n"
+ " * @param x Number The x Co-ordinate being queried\n"
+ " * @param y Number The y Co-ordinate being queried\n"
+ " * @return Number The value at the given co-ordinate, or -1 if the \n"
+ " * co-ordinate is invalid (data will never naturally be less than 0)\n"
+ " **/";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}