use strict;
my $str = '/**
* Queries the data and returns the value for the given x, y cartesian
* pair
* @param x Number The x Co-ordinate being queried
* @param y Number The y Co-ordinate being queried
* @return Number The value at the given co-ordinate, or -1 if the
* co-ordinate is invalid (data will never naturally be less than 0)
**/';
my $regex = qr/@((?:[\s\S](?!\*\/|@))*)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}