import Foundation
let pattern = #"@((?:[\s\S](?!\*\/|@))*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
/**
* Queries the data and returns the value for the given x, y cartesian
* pair
* @param x Number The x Co-ordinate being queried
* @param y Number The y Co-ordinate being queried
* @return Number The value at the given co-ordinate, or -1 if the
* co-ordinate is invalid (data will never naturally be less than 0)
**/
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)