#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ".*-listText-lastMeasurementTimestamp-deviceTable$"
Local $sString = "122eae68-599a-4f95-8cf0-99470740472a_122eae68-599a-4f95-8cf0-99470740472a_0-listText-lastMeasurementTimestamp-deviceTable"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")