const regex = /.*-listText-lastMeasurementTimestamp-deviceTable$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*-listText-lastMeasurementTimestamp-deviceTable$', '')
const str = `122eae68-599a-4f95-8cf0-99470740472a_122eae68-599a-4f95-8cf0-99470740472a_0-listText-lastMeasurementTimestamp-deviceTable`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}