use strict;
my $str = '122eae68-599a-4f95-8cf0-99470740472a_122eae68-599a-4f95-8cf0-99470740472a_0-listText-lastMeasurementTimestamp-deviceTable';
my $regex = qr/.*-listText-lastMeasurementTimestamp-deviceTable$/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}