re = /.*-listText-lastMeasurementTimestamp-deviceTable$/
str = '122eae68-599a-4f95-8cf0-99470740472a_122eae68-599a-4f95-8cf0-99470740472a_0-listText-lastMeasurementTimestamp-deviceTable'
# Print the match result
str.match(re) do |match|
puts match.to_s
end