import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*-listText-lastMeasurementTimestamp-deviceTable$";
final String string = "122eae68-599a-4f95-8cf0-99470740472a_122eae68-599a-4f95-8cf0-99470740472a_0-listText-lastMeasurementTimestamp-deviceTable";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}