using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*-listText-lastMeasurementTimestamp-deviceTable$";
string input = @"122eae68-599a-4f95-8cf0-99470740472a_122eae68-599a-4f95-8cf0-99470740472a_0-listText-lastMeasurementTimestamp-deviceTable";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}