import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^/.]+/(?0)?\\.\\./";
final String string = "out/src/../pictures/all/image.jpg\n"
+ "out/pictures/all/image.jpg\n\n"
+ "deep/hey there/folder/out/src/../../../pictures/all/image.jpg\n"
+ "deep/hey there/out/src/../../pictures/all/image.jpg\n"
+ "deep/hey there/out/../pictures/all/image.jpg\n"
+ "deep/hey there/pictures/all/image.jpg";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}