$re = '~[^/.]+/(?0)?\.\./~';
$str = 'out/src/../pictures/all/image.jpg
out/pictures/all/image.jpg
deep/hey there/folder/out/src/../../../pictures/all/image.jpg
deep/hey there/out/src/../../pictures/all/image.jpg
deep/hey there/out/../pictures/all/image.jpg
deep/hey there/pictures/all/image.jpg';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;