import Foundation
let pattern = #"[^/.]+/(?0)?\.\./"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
out/src/../pictures/all/image.jpg
out/pictures/all/image.jpg
deep/hey there/folder/out/src/../../../pictures/all/image.jpg
deep/hey there/out/src/../../pictures/all/image.jpg
deep/hey there/out/../pictures/all/image.jpg
deep/hey there/pictures/all/image.jpg
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)